2018年04月6日网站服务器迁移完成……

Composer 小技巧 整理

php 苏 demo 994℃ 0评论

1.仅更新单个库

composer update foo/bar

如果遇到问题:
Warning: The lock file is not up to date with the latest changes in composer.json, you may be getting outdated dependencies, run update to update them.

composer update nothing ##Composer不会更新库,但是会更新composer.lock

更新一下 composer.lock 文件即可.
然后在运行就不会有这样的提示了.
当然也可以运行

composer update --lock

如果你的composer 版本足够新.

2. 通过命令引入第三方包,不必再去手动编辑composer.json文件

composer require "foo/bar:1.0.0"  ##同样适用于新开项目composer init --require=foo/bar:1.0.0 -n  参数-n 意思不用回答问题

3.创建项目

composer create-project doctrine/orm path 2.2.0

4.优化自动加载

composer dump-autoload --optimize

安装包的时候可以同样使用–optimize-autoloader。不加这一选项,你可能会发现20%到25%的性能损失.

打赏

转载请注明:苏demo的别样人生 » Composer 小技巧 整理

   如果本篇文章对您有帮助,欢迎向博主进行赞助,赞助时请写上您的用户名。
支付宝直接捐助帐号oracle_lee@qq.com 感谢支持!
喜欢 (0)or分享 (0)
发表我的评论
取消评论
表情